Home : How To Resolve Common Windows Installer Problems
Q11978 - HOWTO: How To Resolve Common Windows Installer Problems

HOW TO RESOLVE COMMON "WINDOWS INSTALLER" PROBLEMS

SUMMARY: 

This article will help you resolve common Windows Installer problems.  Only attempt the instructions in this article if you are an IT professional.  Always backup your system and create restore points before attempting system changes and registry edits.  Contact LEAP SYSTEMS Inc. Technical support staff for help via the:  Live Support- GoToAssist link.

This article was adapted from the following Microsoft support article:  http://support.microsoft.com/kb/555175

SYMPTOMS:

When you try to install/uninstall some application/s, you may get warning messages like:
 

  • "The Windows Installer Service could not be accessed"
  •  "Windows Installer Service couldn’t be started"
  •  "Could not start the Windows Installer service on Local Computer. Error 5: Access is denied."

CAUSE:

The error messages usually appear after failed installation of MSI Package or Disabled "Windows Installer" service.

RESOLUTION:

Method 1
 
Unregister Windows Installer, and then reregister Windows Installer. To do this, follow these steps:

  1. On the "Start" menu, click "Run:.
  2. In the "Open" box, type "msiexec /unreg", and then press ENTER.
  3. On the "Start" menu, click "Run".
  4. In the "Open" box, type "msiexec /regserver", and then press ENTER.

Method 2
 
Upgrade to Windows Installer version 2 or newer version. To do this, follow these steps:

  1. Start Microsoft Internet Explorer, and then browse to the following Microsoft Web site: http://msdn.microsoft.com/downloads
  2. In the left pane tree menu, click "Setup and System Administration", and then click "Setup".
  3. Click "Windows Installer", and then click the appropriate link for your operating system.
  4. Click "Download" to download and install Windows Installer version 2 or newer version.

Method 3
 
Use Windows Installer CleanUp Utility to uninstall the failed product.
Description of the Windows Installer CleanUp Utility http://support.microsoft.com/default.aspx?scid=kb;en-us;290301

Method 4

The Windows Installer service may disabled on the machine.

  1. Go to "Start" -> "Run" , type "services.msc" and press on "Enter" button.
  2. Double-click on the service named "Windows Installer".
  3. Check the value in the "Startup type:"  field. If it's currently set to "Disabled", then this is the problem. Change it by selecting "Manual" from the drop-down box.

Method 5
 
Empty user and system "temp" folders.

  1. Empty "%systemdrive%\temp" folder.
  2. Empty "%systemdrive%\%windir%\temp" folder.
  3. Empty "%systemdrive%\Documents and Settings\%username%\Local Settings\Temp".

Method 6
 
 
Enable Windows Installer Logging and call to PSS support.
 
How to Enable Windows Installer Logging:  http://support.microsoft.com/default.aspx?kbid=223300
 
How to Enable Windows Installer Logging in Windows XP:  http://support.microsoft.com/default.aspx?scid=kb;EN-US;314852

Method 7
 
Check correct DCOM and System permissions:  http://support.microsoft.com/?id=319624

Method 8
 
If you just upgrade Windows XP workstation to service pack 2 and the windows installer problem appear only after this upgrade, please review the following knowledgebase:  http://support.microsoft.com/default.aspx?scid=kb;en-us;885894 

Method 9
 
Check that the installation path length and environment variables length are execute 255 characters  

Method 10
 
If you get the message error "Error 1628: Failed to complete script based install"  And followed the instruction above and it didn’t resolve the problem and you just create fresh installation packet by using InstallShiled tool, please disable "Cache installation on local machine" option during the installation packet create process.

Method 11

Check if there pending installation/s:  Warning: You should only edit these registry entries if you really know what you're doing. Back up your hard disk first.  

  • Empty "InProgress" Registry Key Check the following registry key:  HKLM\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress and clean any entries that you find.
  •  Empty/Rename "PendingFileRenameOperations" Registry Key:  Check the following registry key:  HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations
    and clean any entries that you find.

 Method 12
 
Obtain update MSI Package from the software manufacture. 

MORE INFORMATION:

The Command-Line Options for the Microsoft Windows Installer Tool Msiexec.exe http://support.microsoft.com/default.aspx?scid=kb;en-us;314881
 
Windows Installer 3.1 is available:  http://support.microsoft.com/?id=893803
 
Windows Installer Error Messages:  http://msdn.microsoft.com/library/default.asp?url=/library/en-us/msi/setup/windows_installer_error_messages.asp
 
PRB: "Setup Has Detected That Another Program Requires the Computer to Reboot" Error Message When You Try to Install Visual Studio .NET: 

http://support.microsoft.com/default.aspx?scid=kb;en-us;830608

APPLIES TO:

  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition 2002
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Small Business Server 2000 Standard Edition
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http://leapsystems.com/kb/article.aspx?id=12308
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Created on 9/23/2009.
Last Modified on 2/4/2011.
Last Modified by Tom Clancy.
Skill Level: Intermediate.
Article has been viewed 7559 times.
Rated 5 out of 10 based on 39 votes.
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